Incident update or process action fails

Problem

Some incidents are not exchanged between Service Manager and SAP Solution Manager. The log file or console message of SMSSMEX displays WARN or FATAL level information as described below.

  1. Service Manager sends an incident to SAP Solution Manager:

    WARN com.hp.ov.ictex - Failed to process action addinfo as the incident is locked by the external helpdesk. Request will be sent again later.

    The following alert may appear in Service Manager:

  2. SAP Solution Manager updates the incident to Service Manager.

    DEBUG com.hp.ov.ictex - Failed to update incident. id:IM10068
    DEBUG com.hp.ov.ictex - Response code = 3. Probably an Incident: IM10068 is locked.
    FATAL com.hp.ov.ictex - Saving of incident failed. Received Message from ServiceCenter: Resource Unavailable
    null
    FATAL com.hp.ov.ictex - An error occured while processing incident ID IM10068. Message: Resource Unavailable
    null
    DEBUG com.hp.ov.ictex - An error occured while processing incident ID IM10068. Message: Resource Unavailable
    null
    com.hp.ov.ictex.ovhdaccess.OvHDException: Resource Unavailable
    null
    at com.hp.ov.ictex.ovhdaccess.servicecenter.Incident.save(Unknown Source)
    at com.hp.ov.ictex.exthdrequesthandler.OvictexServer.updateIncident(Unknown Source)
    ...

Cause

The incident in Service Manager or SAP Solution Manager is locked:

  1. In SAP Solution Manager, if the user does not click the button Display/Change Trans to release an incident write lock, Service Manager can not update or send a message to SAP.
  2. In Service Manager, if the user does not click OK to release an incident write lock in time, the incident maintains the “Updating” status and no message from SAP can be accepted (until the status changes).

Solution

In SAP Solution Manager always click Display/Change Trans after finishing or updating an activity.

In Service Manager, click OK after finishing or updating an activity.