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be present in this PDF version. Those topics can be successfully printed from within the online help.
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Survey introduction
Prior to version 9.40, HP Service Manager allowed you to set up a scheduled survey only through survey

integration. As of version 9.40, Service Manager additionally provides a Service Manager Survey tool,

which enables you to implement email surveys in Service Manager independently without integration

with third party survey tools. With this tool, you can either manually send a survey from a record, or set

up scheduled surveys.
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Service Manager Survey
The Service Manager Survey (SM Survey) feature is based on the HTML Email solution (JavaMail) and

does not require an external survey tool to complete the survey process. You can manually send

individual surveys directly form a record to selected users, or configure the system to automatically

send scheduled surveys to specified users through an out-of box SM Survey connector.

When users receive a survey link, they can directly open the link in a web browser and then log in to

Service Manager to complete the survey. They can also check the surveys opened for them or closed by

them in the Service Manager portal. In the out-of-box system, SM surveys are designed to achieve the

following goals:

l Collect user satisfaction ratings on the following areas: the level of service provided, the speed of

response that the user received, and the level of communication rating from 1 to 5 regarding the

service.

l Collect additional comments from the user (if any)

l Allow the user to select if a complaint or compliment needs to be registered. If the user selects to do

so, the system automatically generates an interaction record of a Complaint or Compliment

category with the information the user provided, and sends an email to the user with information

about the interaction record. The user can click the record link to check the record details and

status.

Note: SM Survey does not support Multiple Company mode.

Once the surveys are completed and submitted, the survey senders can check the survey results from

the TO-DO queue or from the Survey menu on the system navigator. In addition to individual survey

results, administrators can also check the statistics reports that the system automatically generates

based on the existing survey results. All this can help your organization to improve your services and

user satisfaction.

SM Survey setup
SM surveys fall into two categories: manual surveys and scheduled surveys. You need to configure the

two types of SM surveys differently.
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Common configurations

Both types of SM surveys require the following configurations:

l The HTML Email solution must be set up. For details, see "Set up HTML Email for SM surveys" below.

l The web tier URLs must be set up in the System Information Record. This is because both types of

SM surveys use the web tier URLs (index.do or ess.do) in the survey links that are sent to the

recipients. For details, see "Configure web tier URLs for SM surveys" on the next page.

Once these configurations are ready, you can send manual SM surveys from a record by selecting the

Send Survey option. However, scheduled SM surveys require additional configurations.

Additional configurations for scheduled SM surveys

Scheduled surveys are based on the survey integration framework, and therefore require the following

additional configurations:

l A survey integration instance is set up and enabled in Integration Manager. For details, see "Enable a

survey integration instance" on page 11.

l Desired recipients are predefined in the SM Survey connector. For details, see "Configure the survey

recipients" on page 31.

l A survey definition for each supported module is created based on the SM Survey connector. For

details, see "Create an SM survey for a module" on page 11.

You can create an SM survey for each of the following modules: Change, Configuration Item,

Interaction, Incident, Request, and Problem.

Set up HTML Email for SM surveys

User roles: System Administrator

For the SM Survey feature to work, you need to set up HTML Email (JavaMail) by configuring the required

emailout parameters. For more information about the emailout parameters, see "Emailout parameters

in the sm.ini file" on page 1.

To set up HTML Email, follow these steps:
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1. Navigate to the RUN folder of the Service Manager server.

2. Open the sm.cfg file in a text editor, and add the emailout parameter in the file:

sm -emailout

3. Open the sm.ini file in the RUN folder, and add the following emailout parameters:

smtphost:smtp3.mycompany.com
smtpport:25
mailFrom:sender@mycompany.com

Where: smtphost is the name of the SMTP server host for client requests, smtpport is the

communications port that the SMTP server uses, and mailFrom is any email address that you want

to appear as the sender in the survey emails. The mailFrom parameter must use an email address

format, but does not have to be a real email address.

Tip: Instead of configuring the parameters in the two configuration files, you can also

configure all of these emailout parameters in the sm.cfg file:

sm -emailout -smtphost:smtp3.mycompany.com -smtpport:25 -

mailFrom:sender@mycompany.com

4. Save the files and restart the Service Manager server.

Next, you need to configure the Service Manager web tier URLs in the System Information Record if

you have not already done so. For details, see "Configure web tier URLs for SM surveys" below.

Configure web tier URLs for SM surveys

User roles: System Administrator

SM surveys are sent to recipients with survey links, which includes the Service Manager web tier URL

(ess.do). For this reason, you must configure the web tier URLs in the System Information Record.

To configure the web tier URLs, follow these steps:

1. Click System Administration > Base System Configuration > Miscellaneous > System Information

Record.

2. Click the Active Integrations tab.
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3. In the WebServer URL field, type the fully qualified index.do URL to your web tier. For example:

http://myserver.mydomain.com:myport/SM/index.do

4. In the ESS URL field, type the fully qualified ess.do URL to your Web tier. For example:

http://myserver.mydomain.com:myport/SM/ess.do

5. Save the system information record.

6. Restart the Service Manager server.

If you have already set up HTML Email, now users can send surveys from a record by using the Send

Survey option from the More menu.

However, to enable the system to automatically send scheduled surveys, additional configurations

are needed:

"Enable a survey integration instance" below

"Create an SM survey for a module" below

Enable a survey integration instance

User roles: System Administrator

Scheduled SM surveys are based on the survey integration framework. The major difference between

the scheduled SM Survey feature and the survey integration is that the former uses an SM Survey

connector while the latter uses an connector for an external survey tool. They both require a survey

integration instance be set up and enabled in the Integration Manager and the survey service agent

scheduler be started in System Status.

For detailed steps, see "Create a Survey Integration instance " on page 19.

Create an SM survey for a module

You can create a survey definition for scheduled SM surveys applicable to any of the following modules:

Change, Configuration Item, Interaction, Incident, Request, and Problem.

To create a new scheduled SM survey for a module, follow these steps:
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1. Click Service Desk > Survey Management > Create Survey in the system navigator to display the

Create a New Survey wizard.

2. Select Internal Connector from the connector list.

3. Select the Service Manager module on which the survey will be based from the Object drop-down

list. For example, select Interaction.

4. Select an assignment group in the Owner Group field. For example, select Coordinator.

5. In the Name field, enter a descriptive name for the survey.

6. Click Finish to display the survey definition record.

7. (Optional) Enter a description for the survey definition as needed.

8. Configure the scheduling rules as described below.

a. Select a Sending Interval value. For example, select Daily.

b. In the Active From and To fields, specify a future time period during which the survey

definition will be active.

9. In the User Selection Rules section, select one or more rules. For example, select Randomly select

10% users as survey recipients.

10. Specify a predefined filter. For example, select Closed interactions since last processing.

You can define custom filters. For details, see "Create an additional filter" on page 30 in the Survey

Integration section.

11. In the Recipients section, select recipients for the survey definition. For example, select Contact.

An available recipient here is actually a mapping field in the corresponding DBDICT record, which is

defined in the Internal Connector and can be either the group or the person type. To view or update

the out-of-box recipient setting, follow these steps:

a. Go to System Administration > Ongoing Maintenance > Survey > Survey Connectors, and

open the Internal Connector through a search.

b. Browse to the Recipients and Parameters section and add new parameters as needed. For

example, in the out-of-box system, for Interactions, recipient Contact is mapped to the

callback.contact field in the incidents DBDICT record, which is the Contact field in the
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interaction detail form. For more information about how to add a new recipient for a module,

see "Create a new recipient" on page 23.

12. In the Email Settings section, manually configure your email template or click Select HTML

Template to select an existing one. Service Manager provides an out-of-box HTML template as

Internal Survey Template. In the Test Record field, enter an existing record ID (for example,

SD10002), and click Preview to make sure the template satisfies your needs.

13. Click Back to return to the survey definition.

14. Click Add Translation if you want to add a localized version of the email template. For details, see

"Create a localized email" on page 32.

15. (Optional) In the Parameters section, click the Optional tab to add your own parameter mappings.

Parameters are predefined values that provide surveys in HP Service Manager with the correct

metadata. You can create additional parameters that are mapped to specific fields in the module.

16. Click Save to create the survey definition.

SM Survey administrator tasks
The scheduled SM Survey feature shares the same framework as the survey integration. Most of the

administrator tasks are the same as those for the survey integration. See the following topics in the

Survey Integration section.

"Configure the global survey settings" on page 20

"Create a new parameter" on page 22

"Create a new recipient" on page 23

"Create a predefined filter" on page 23

The following administrator tasks are only for scheduled Service Manager Survey.

"Design your own SM Survey questionnaire" on the next page

"Tailor the SM Survey template" on the next page

"Manage the self-service survey menu" on page 15
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Design your own SM Survey questionnaire

User roles: System Administrator

In the out-of-box system, the following questions are provided for SM surveys:

1. Overall, how satisfied are you with the level of service provided (1 - "Very Unsatisfied" and 5 - "Very

satisfied")?

2. How satisfied are you with the speed of response that you received (1 - "Very Unsatisfied" and 5 -

"Very satisfied")?

3. How satisfied are you with the communication regarding the service (1 - "Very Unsatisfied" and 5 -

"Very satisfied")?

4. Do you have any additional comments?

These four out-of-box questions are defined in the SurveyInternal table. However, you may need to

update the questions according to your business needs. To tailor your own survey questions and

options, follow these steps:

1. Add new fields in the SurveyInternal dbdict record.

2. Modify the corresponding SurveyInternal format.

You can also add verification to a question, and Service Manager will verify if the recipients have

answered this question when they submit the survey. For the four out-of-box questions, Service

Manager adds verification to the first three questions. If you want to add verification to your new

questions, update the SurveyInternal format control and then make sure this question is marked with

an asterisk (*) when you design the corresponding format in the Forms Designer.

Tailor the SM Survey template

User roles: System Administrator

When you manually send a survey from a record, an SM Survey template is applied to generate the

default subject and message body. You can tailor the content in the template or use your own template

to replace the default SM Survey template.

To tailor the default SM Survey template, follow these steps:
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1. Click Tailoring > Notifications > HTML Templates.

2. Enter Internal Survey Template in the Name field and click Search.

3. Update the survey template content based on your requirements.

4. Click Save to save the updated template.

To replace the default SM Survey template, follow these steps:

1. Click Tailoring > Notifications > Notifications.

2. Enter Send Survey in the Name field and click Search.

3. In the Arguments column corresponding to the HTMLTemplate class, replace the string "Internal

Survey Template" in the jscall function with your new template name. You need to make this

update in both the Message and the Email/Mail Subject Line tabs.

4. Click Save to save the updated notification definition.

Manage the self-service survey menu

User roles: System Administrator

SM Survey menu is added to out-of-box self-service menus, which allows an end user to view and

complete an SM survey. You can update an operator record to grant survey access by assigning the

ESSSM-Survey self-service menu.

There are multiple self-service menus available, you can choose to assign only the SM Survey menu to

an operator. To do this, follow these steps:

1. Click System Administration > Ongoing Maintenance > Operators.

2. Type or select the optional search criteria.

3. Click Search.

4. Select an existing operator record.

5. Click the Self Service tab. Make sure that the operator record has these settings:
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o The Self Service Access Only check box must be selected.

o Select or type ESSM-Survey in the Self Service Menu field. In this way, the SM Survey menu is

displayed when this user logs on using a self-service URL.

6. Click Save.

SM Survey user tasks
Once the SM survey feature is set up, users can perform the following tasks.

"Send a survey from a record" below

"Respond to an SM survey" on the next page

"Check my SM surveys" on page 18

Send a survey from a record

User roles: users

Once your administrator has set up HTML Email and configured the web tier URLs in the System

Information Record, you can manually send a survey from a record at any state in one of the following

modules:

l Interaction

l Request

l Incident

l Problem

l Change

l Configuration Item

To manually send an SM survey from a record, follow these steps:

1. Open a record. For example, open an interaction record.

2. Click More > Send Survey to display the Manual Customer Survey interface.
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3. Click Fill to select one or more recipients from the list.

4. Click Send to send the survey to the selected recipients.

Note: If you type an email address instead of selecting a recipient from the list, Service

Manager sends a survey email to the corresponding user. If no corresponding user is found,

Service Manager sends the email directly to this email address.

The specified recipients receive an email notification, which contains a survey link and instructions on

how to respond to this survey.

Respond to an SM survey

User roles: users

If you receive an email notification inviting you to respond to an SM survey, follow the instructions to

view and respond to the survey.

To view and respond to an SM survey, follow these steps:

1. Open the survey link in a web browser.

The Service Manager login screen appears.

2. Log in to Service Manager.

3. Click Survey > View Open Surveys.

4. Click the survey number to open the survey.

5. Select your answers to the survey questions.

6. (Optional) Enter additional comments.

7. (Optional) Click Register a compliment or Register a complaint.

If you select either option, the system will automatically create an interaction record that has a

category of Compliment or Complaint and send you another email with the record details after you

submit the survey. By default, the No interaction registration option is selected.
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8. Click Submit Survey.

The survey now appears in your list of closed surveys ( Survey > View Closed Surveys).

Check my SM surveys

User roles: users

You have two ways to check your SM surveys, including those that you have sent out and those that you

have responded to.

To check your SM surveys from the TO-DO queue, follow these steps:

1. From the TO-DO queue, select Internal Survey.

2. Select a desired SM survey view.

To check your SM surveys from the navigator, follow these steps:

1. Click a survey link in the email your received, and log in to Service Manager.

2. Click Survey from the system navigator and then select View Open Surveys or View Closed

Surveys.
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Survey Integration
HP Service Manager Survey integration enables you to effectively configure and manage the surveys in

your organization.

Survey Integration includes three integration methods (connectors) that enable you to integrate Service

Manager with third-party survey tools.

Create a Survey Integration instance
Before you can create and configure surveys in HP Service Manager Survey Integration, you must create

a survey integration instance. Survey Integration only requires one survey integration instance, even if

you have multiple surveys. Once you have created a survey integration instance, you cannot create a

second one.

To create a survey integration instance, follow these steps:

1. In the System Navigator, click Tailoring > Integration manager > Add.

2. Select SMSurvey from the Integration Template drop-down list, and then click Next.

3. Populate the Interval Time and Max Retry Times fields.

4. Click Next four times or until the Survey Integration instance is created.

5. Click Enable to enable the integration.

Note: Additionally, you must ensure that the survey service agent scheduler is started after you

create the instance.

Survey administrator tasks
This section introduces administrator tasks for survey integration.

Configure the global survey settings 20

Create a new survey connector 21

Search for a survey connector 21

Create a new parameter 22
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Create a new recipient 23

Create a predefined filter 23

Configure the global survey settings

The System Administrator can configure a number of settings that apply to every survey in HP Service

Manager scheduled SM survey and Survey Integration. To view and configure these settings, click

System Administration > Ongoing Maintenance > Survey > Survey Settings.

The Survey Settings form contains the following configurable attributes.

Attribute Description Notes

Additional Filter Configuration
Item form

The form that is used to filter additional
records against the device table. You can
create your own forms that have the filter
fields you require.

This attribute is
mandatory.

Additional Filter Change form The form that is used to filter additional
records against the cm3r table. You can
create your own forms that have the filter
fields you require.

This attribute is
mandatory.

Additional Filter Incident form The form that is used to filter additional
records against the probsummary table. You
can create your own forms that have the
filter fields you require.

This attribute is
mandatory.

Additional Filter Problem form The form that is used to filter additional
records against the rootcause table. You can
create your own forms that have the filter
fields you require.

This attribute is
mandatory.

Additional Filter Interaction form The form that is used to filter additional
records against the incidents table. You can
create your own forms that have the filter
fields you require.

This attribute is
mandatory.

Link for copy (default:
SurveyDefinition.copy)

Enables you to specify a link to decide which
fields are copied from the source to the
target record.

Default language The language in which the survey email is
sent when no localized version is available in
the recipient's language.

This attribute is
mandatory.

HTML format for email body Specifies the form that contains the HTML
email body.

This attribute is
mandatory.
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Attribute Description Notes

Plain text format for email body Specifies the form that contains the plain
text email body.

This attribute is
mandatory.

Use HTML emails When this option is selected, the HTML editor
is displayed in the survey definition record. If
the option is not selected, a plain text editor
is displayed instead.

Use HTML templates When this option is selected, HTML templates
are available to help you create survey
emails.

Create a new survey connector

In addition to the out-of-box survey connectors, you can create new survey connectors in HP Service

Manager Survey Integration. To do this, follow these steps:

1. In the system navigator, click System Administration > Ongoing Maintenance > Survey > Survey

Connectors > New to display a blank connector form. The ID, Last Updated by, and Last Update

time fields are populated automatically.

2. Click to clear the Active checkbox if you do not want the new survey connector to be displayed in

the list of available survey connectors when you create a new survey.

3. Select a connector type from the drop-down list in the Type field.

4. Type a name for the connector in the Name field.

5. Type a description of the connector in the Description field.

6. Click Save to save the connector. The Parameters and Recipients section of the form is displayed.

Search for a survey connector

To search for an existing survey connector in HP Service Manager, follow these steps:

1. In the system navigator, click System Administration > Ongoing Maintenance > Survey > Survey

Connectors.

2. Use the search form to specify search criteria. For example, in the Type drop-down list, select Send
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emails with a survey link.

3. Click Search to display the list of records that match your search criteria.

Note: If Service Manager generates a message that states no records were found, you can

broaden the search by eliminating some search parameters.

Create a new parameter

Parameters are predefined values that provide surveys in HP Service Manager with the correct

metadata. Survey Administrators can create additional parameters that are available to survey users

when they configure a survey connector. Parameters are associated with specific Service Manager

modules.

To create a new parameter, follow these steps:

1. Open a survey connector by creating a new connector or by searching for an existing connector.

2. Browse to the Parameters and Recipients section, and then expand the Service Manager module

to which you want to add a parameter.

3. Expand Parameters, and then click Add Parameter to display the Survey Parameter Mapping form.

The ID, Connector ID, Last update time, Last updated by, and Object fields and the Active check-

box are populated automatically.

4. Type a user-friendly description of the parameter in the Description field.

5. Type the internal name for the parameter in the Parameter Name (Internal) field.

6. Select the order in which the parameter is processed in the Order ID field (this step applies only to

API-based connectors).

7. Select a mapping type from the Mapping Type drop-down list.

8. Type a constant value, variable, field name, or RAD expression in the Mapping Value field, and then

click Save.
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Create a new recipient

Survey Administrators can create predefined recipients that are available to survey users when they

assign recipients to a survey in HP Service Manager. Recipients are associated with specific Service

Manager modules.

To create a new recipient, follow these steps:

1. Open a survey connector by creating a new connector or by searching for an existing connector.

2. Browse to the Parameters and Recipients section, and then expand the Service Manager module

to which you want to add recipients.

3. Expand Recipients, and then click Add Recipient to display the Survey Recipients Configuration

form. The ID, Connector ID, Last update time, Last updated by, and Object fields and the Active

check-box are populated automatically.

4. Type a user-friendly description of the recipient in the Description field.

5. Type the internal name for the recipient in the Parameter Name (internal) field.

6. Select a mapping type from the Mapping Type drop-down list.

7. Select a recipient type from the Recipient Type drop-down list.

Note: If you select Group as the recipient type, you must also select values from the Group

and Subgroup drop-down lists.

8. Type a constant value, variable, field name, or RAD expression call in the Recipient(s) field, and

then click Save.

Create a predefined filter

Data filters enable you to configure which records in the database are selected to be recipients of HP

Service Manager survey requests. Survey Administrators can create predefined filters, which are

available for survey users to choose from, by creating views in Service Manager.

To create a view to use as a predefined filter, follow these steps:
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1. In the system navigator, click System Administration > Base System Configuration >

Miscellaneous > Views/Favorites > New.

2. Select an object from the Area drop-down list, and then click Next.

3. Type a name in the Name field, select a view type from the View type drop-down list, and then

click Next.

4. Select the Selected Groups option, click to select the Survey group, and then click Next.

5. Configure the parameters for the view, and then click Finish.

To ensure the survey solution can filter for records that are exclusively related to data the survey, the

"@FieldName@" directive is added to the filter queries. When the query is run, the directive is replaced

by the value in the specified field. For example, the following query filters for records that were closed

since the last survey run:

close.time>@lastProcessingTime@

Note:

l Ensure that you configure the predefined filter so that the system can process all the records

within the configured send interval.

l The filter results must be ordered correctly to ensure that the required users are surveyed. This

is because Survey selects records in the order in which they appear in the database after a

query is run.

Survey user tasks
This section introduces the Survey Integration user tasks.

Create a survey from menu 25

Search for a survey 25

Configure the survey header 26

Add an activity to the Survey Activities log 28

Configure the survey scheduling rules 28

Filter the survey recipients 29
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Apply a data filter to a survey 30

Create an additional filter 30

Configure the survey recipients 31

Configure the survey email settings 31

Create a localized email 32

Configure the survey parameters 33

View the survey workflow 33

View the survey history 34

Create a survey from menu

To create a new survey in HP Service Manager Survey Integration, follow these steps:

1. Click Service Desk > Survey Management > Create Survey in the system navigator to display the

Create a New Survey wizard.

2. If there is more than one survey connector, select a survey connector from the list. The Connector

type field is populated automatically, based on your choice of connector.

3. Select the Service Manager module on which the survey will be based from the Object drop-down

list.

4. Enter values in the Owner Group and Name fields.

5. Click Finish to display the survey definition record.

6. Populate all the mandatory fields in the survey definition record to configure the survey. For more

information about how to configure a survey, refer to the "Related tasks" section.

7. Click Save to create the survey record.

Search for a survey

To search for an existing survey definition record in HP Service Manager Survey Integration framework,

follow these steps:
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1. In the system navigator, click Service Desk > Survey Management > Search Surveys.

2. Use the search form to specify search criteria. For example, in the Current Phase field, select

retired.

3. Click Advanced Filter to create custom filters. To create new search criteria, follow these steps:

a. Click Add New Filter Criteria.

b. Populate all the fields as required, and then click Next to add the criterion to the Conditions

list.

c. Click Add New Compound to add a compound rule to a filter that has more than one criterion.

4. Click Search to display the list of records that match your search criteria.

Note: If Service Manager generates a message that states no records were found, you can

broaden the search by eliminating some search parameters.

Configure the survey header

The Header section of the survey management form in HP Service Manager Survey Integration contains

the survey metadata. The content of the section is dependent on whether the survey uses a URL-based

or API-based connector.

Surveys that use a URL-based connector

To configure the survey header of a survey that uses a URL-based connector, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. The Active check-box and the following fields are populated automatically:
o ID

o Object

o Current Phase

o Connector Type
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o Owner Group

o Name

3. Type a value in the External Survey ID field.

4. Type values in the Owner and Description fields, and then click Save.

Surveys that use an API-based connector

To configure the survey header of a survey that uses an API-based connector, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. The Active and Keep Default Connection check-boxes and the following fields are populated

automatically:
o ID

o Object

o Current Phase

o Connector Type

o Owner Group

o Name

3. Type a value in the External Survey ID field.

4. Type values in the Owner and Description fields.

5. To create a custom connection to the survey solution, follow these steps:

a. Clear the Keep Default Connection check-box to display the Connection Parameters sub-

section.

b. Type the URL, user name, and password that are required to connect to the survey solution.

6. Click Save.
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Add an activity to the Survey Activities log

The Activities section of the survey definition record in HP Service Manager Survey Integration displays

the major activities that are associated with the survey, and enables users to add an activity to the

record. To add an activity, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. Scroll down to the Activities section.

3. Select the type of update that you want to add from the New Update Type drop-down list.

4. Type a description of the update in the New Update field, and then click Save.

Note: If numerous activities are recorded, you can restrict the number that are displayed. To do

this, select a type of activity from the Activity Type drop-down list, and then click Filter.

Configure the survey scheduling rules

The Scheduling Rules section of the survey definition record in HP Service Manager Survey Integration

enables you to configure the duration of the survey and how often survey requests are sent out.

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. Scroll down to the Scheduling Rules section.

3. Select the interval at which survey requests are sent from the Send Interval drop-down list.

Note: Survey Administrators can configure the options that appear in the Sending Interval

drop-down list by modifying the SurveySendInterval types in the Code table. The value is in

seconds.

4. Enter the survey start date in the Active From field.

Note: This date cannot be in the past.

5. Enter the survey end date in the To field, and then click Save.

Note: This date must be later than the date in the Active From field.
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To configure a survey that runs one time only, follow these steps:

1. In the Scheduling Rules section of a survey definition record, set the Send Internal field to Every

hour.

2. Set the Active From field to the start time that you require.

3. Set the To field to a time that is 10 minutes later than the time that you entered in the Active

from field.

Note: If the time difference between the Active From and the To fields is less than 5 minutes, the

survey may not run.

Filter the survey recipients

The User Selection Rules section of the survey definition record in HP Service Manager Survey

Integration enables you to configure how often users are sent survey requests and the percentage of

users that are sent a survey request. To filter the survey recipients, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. Scroll down to the User Selection Rules section.

3. Select one or more of the following options:
o Do not survey a user more than once in a survey cycle

When this option is selected, users who appear in the survey database more than once are not

sent multiple survey requests.

o Do not send a user a new survey for <time>

When this option is selected, you can configure a period of time in which users are not sent new

survey requests.

o Randomly select <percentage> % of users as survey recipients

When this option is selected, you can configure the percentage of users that are sent a survey

request.

4. Click Save.
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Apply a data filter to a survey

The Data Filter section of the survey definition record in HP Service Manager Survey Integration

enables you to configure which records in the database are selected to be recipients of survey requests.

The section comprises of predefined filters (that are managed by the Survey Administrator) and

additional filters (that are user-generated). The two types of filter are connected with an AND operator.

To apply a data filter, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. Scroll down to the Data Filter section.

3. Select a predefined filter.

4. Create an additional filter, and then click Save.

Create an additional filter

Data filters enable you to configure which records in the database are selected to be recipients of in HP

Service Manager Survey Integration survey requests. Additional data filters can be created by users to

supplement the predefined data filters.

To create an additional data filter, follow these steps:

1. Open a survey definition record, and then browse down to the Data Filter section.

2. Click Build Additional Filter to display the Query Generator form.

3. Populate the appropriate fields with values to create the required filter.

4. Click Advanced Filter to create custom filters. To create new search criteria, follow these steps:

a. Click Add New Filter Criteria.

b. Populate all the fields as required, and then click Next to add the criterion to the Conditions

list.

c. Click Add New Compound to add a compound rule to a filter that has more than one criterion.

5. Click OK to display the additional data filter in the Data Filter section of the survey management

form, and then click Save.
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To ensure the survey solution can filter for records that are exclusively related to data the survey, the

"@FieldName@" directive is added to the filter queries. When the query is run, the directive is replaced

by the value in the specified field. For example, the following query filters for records that were closed

since the last survey run:

close.time>@lastProcessingTime@

Configure the survey recipients

The Survey Recipients section of the survey definition record in HP Service Manager Survey Integration

enables you to configure the recipients of survey requests. Recipients are defined in the survey

connector, and are based on the specific Service Manager module to which the survey applies.

To configure the survey recipients, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. Scroll down to the Survey Recipients section.

3. Select a recipient from the Available Recipients box, and then click the right arrow to move the

recipient to the Selected Recipients box.

Note: To remove a recipient from the Selected Recipients box, select the recipient, and then

click the left arrow.

4. Click Save.

Configure the survey email settings

The Email Settings section of the survey definition record in HP Service Manager Survey Integration

enables you to configure the email survey requests that are sent for surveys that use URL-based

connectors.

To configure the email settings, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. Scroll down to the Email Settings section.

3. Type the URL of the external survey in the External Survey URL field.

4. Type an email subject in the Email Subject field.
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5. Type the email body text in the Email Body field. Or, click Select HTML Template to use an out-of-

box template.

Note: HTML templates are only available if this option is selected in the global survey settings.

6. To preview the email, type a value in the Test Record field, and then click Preview.

Note: You can reference parameter names in the External Survey URL, Email Subject, and Email

Body fields. For example, you can type "Survey for record {interactionId}" as the subject, where "

{interactionId}" is a parameter for the interaction ID that triggered the survey request.

Create a localized email

The Survey Integration email functionality in HP Service Manager Survey Integration enables you to

create alternate language versions of the survey request email. Survey recipients receive a localized

email if their default language matches the language of the localized email. Otherwise, the user

receives the default language version of the email that is configured in the global survey settings,

regardless of the user's default language.

To create a localized email, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. Scroll down to the Email Settings section.

3. Configure the default language survey request email, and then click Save.

4. In the Translations sub-section, click Add Translation to display the Survey Email Localization

form. The ID, Last updated by, and Last update time fields are populated automatically.

5. Select a language from the Language drop-down list.

Note:

o The default language that is configured in the global survey settings does not appear in

this list.
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o System administrators can configure which languages appear in the list by using the

Languages table. To include a language, select that language in the Languages table, and

then select the Active for Survey Management option.

6. Type a subject in the Email Subject field.

7. Type the email body text in the Email Body field.

8. Click Save, and then click Cancel to return to the survey definition record.

Configure the survey parameters

The Parameters section of the survey definition record in HP Service Manager Survey Integration

enables you to configure the survey parameters that are not inherited from the connector. Parameters

are defined in the survey connector, and are based on the specific Service Manager module to which the

survey applies.

To configure the survey parameters, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. Scroll down to the Parameters section.

3. Mandatory parameters are predefined by the connector. To create additional parameters, click

Optional.

4. Type a name in the Parameter Name field, select a field from the Field Name drop-down list, type

a description of the parameter in the Description field, and then click Save.

View the survey workflow

HP Service Manager Survey Integration incorporates Process Designer technology. To view the Survey

Integration workflow, click System Administration > Ongoing Maintenance > Survey > Survey

Workflows, and then double-click the survey workflow. The survey workflow is also displayed in the

Workflow section of the survey definition record.

To view specific information about a transition or phase in the survey workflow, click the transition or

phase.

Out-of-box Survey Integration workflows comprise the following three phases.
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Phase Description

Planning The survey manager configures survey settings such as data filters, recipients,
and parameters. Survey invitations are not sent during this phase.

Scheduled The survey runs for the configured period. The majority of settings are no
longer editable during this phase.

Retired The survey is no longer active.

Note: When the date that is configured in the Active To field of the survey settings passes, the

survey automatically transitions from the Scheduled phase to the Retired phase.

View the survey history

The History section of the survey definition record in HP Service Manager Survey Integration displays

basic information about the life of a survey. The fields in this section cannot be edited.

To view the survey history, follow these steps:

1. Open a survey definition record by creating a new survey or by searching for an existing survey.

2. Scroll down to and expand the History section to display the following information:
o Who created the survey

o When the survey was created

o Who last updated the survey

o When the survey was last updated

o Who retired the survey

o When the survey was retired

3. Click the Show Send History button to display the following information:
o When the survey was sent

o The status of the uploaded and sent data

o Detailed information about the uploaded and sent data
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4. Click the Show Send Log button to display the following information:
o When the survey was sent

o The recipient of the survey request email

o The record that triggered the survey

Survey Integration referencematerial
This section introduces the Survey reference material.

Survey connectors 35

Security areas 36

Security roles 36

Parameter mapping 38

Recipient mapping 39

Survey connectors

The survey connector is the integration method that SM Survey and Survey Integration use to send

survey data to survey recipients. The survey connector defines some elements of the survey, such as

the survey parameters, survey recipients, and connection parameters.

Out-of-box deployments of Survey contain the following types of connector. For scheduled SM surveys,

users can create surveys based on the out-of-box internal connector and there is no need to create any

new connectors.

ID Name Description

001 API Connector - Market Tools An API-based connector that
uploads data directly to the
Market Tools survey solution

002 URL Connector An URL-based connector. When
you use this connector to
manage a survey, survey
recipients are emailed a URL that
points to the survey

003 API Connector - Medallia An API-based connector that
uploads data directly to the
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ID Name Description

Medallia survey solution

004 Internal Connector The internal connector for
scheduled SM survey using
Internal URL

To view the available survey connectors, follow these steps:

1. In the system navigator, click System Administration > Ongoing Maintenance > Survey > Survey

Connectors to display the Survey Connector form.

2. Enter search criteria into any of the fields, and then click Search.

Security areas

HP Service Manager Survey Integration includes two security areas that ensure correct security in the

Time Period Management module.

The following table displays the mapping between the security areas and the security roles in Service

Manager Survey.

Area Applies to interactions in Roles

Survey Survey definitions Survey Administrator

Survey Analyst

Survey Manager

Survey configuration Survey connectors Survey Administrator

Tailoring Survey settings

Survey workflow

Survey Administrator

Security roles

HP Service Manager Survey uses the following three security roles.

Role Area Rights
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Survey
Administrator

Survey Full rights for area

Survey
configuration

Full rights for area

Survey Analyst Survey Partial rights for area (can only update assigned surveys and
cannot un-retire surveys)

Survey
Manager

Survey Full rights for area (can always update all survey definition
records)

The following rights can be configured for Survey Integration security roles.

Right Description

View Can view survey definition records

New Can create new survey definition records

Update Determines when a user can update a survey. This right has the following options:

l Never

l Always

l When assigned

l When assigned to workgroup

Delete / Close Determines when a user can retire a survey. This right has the following options:

l Never

l Always

l When assigned

l When assigned to workgroup

Expert No special functionality related

Admin Has administrative rights (by default, full rights to the survey module)

Note: The When assigned and When assigned to workgroup values in the Update and

Delete/Close fields are not supported in the Survey Configuration security area.

The following settings can be configured for Survey Integration security roles.

Setting Description
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Can copy record Can copy survey definition records

Can create global
inbox

Can create global time period inboxes

Initial Inbox Initial inbox for time period module

Manage format Sc manage format

Can create personal
inbox

Can create personal inboxes for survey definition records

Un-retire Can un-retire (reopen) survey definition records

New Thread List ->
Edit

Determines whether a new thread is opened when a user moves from a List
to an Edit screen

New Thread Search -
> List

Determines whether a new thread is opened when a user moves from a
Search screen to a List

New Thread View ->
Edit

Determines whether a new thread is opened when a user moves from an
Inbox to an Edit screen

New Thread View ->
Search

Determines whether a new thread is opened when a user moves from an
inbox to a Search screen

Parameter mapping

The following mapping types are available when you create a new parameter in HP Service Manager

Survey Integration framework.

Predefined
mapping type Description Example syntax

Value A constant value l John.doe@hp.com (email)

l jdoe (operator name)

l DOE, JOHN (contact name)

Variable Any variable that is available when the
survey runs

$G.serviceDesk

Field A valid field name in the selected Service
manager module

Incident.id

RAD expression Any valid RAD expression that returns the
required value

jscall(<lib.function>,
contact.name in $L.file)

Predefined The following predefined options are
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available:

l Recipient Email

l Recipient Name

l Language

l Web URL

l ESS URL

l External URL

Recipient mapping

The following mapping types are available when you create a new recipient in HP Service Manager

Survey framework.

Predefined
mapping
type Description Example Syntax

Value A constant value. This value must be a valid email address,
contact name, or operator name. Multiple values can be
entered and must be separated by a semi-colon (;).

l John.doe@hp.com
(email)

l jdoe (operator
name)

l DOE, JOHN
(contact name)

Variable Any variable that is available when the survey runs. If the
recipient type is set to Person, this value must be a valid email
address, contact name, or operator name. If the recipient type
is set to Group, this variable must contain a valid group name.

l $G.serviceDesk
(person)

l $lo.pm.assignmen
t (group)

Field A valid field name in the selected Service manager module. If
the recipient type is set to Person, this value must be a valid
email address, contact name, or operator name. If the recipient
type is set to Group, this variable must contain a valid group
name.

l contact.name
(person)

l assignment
(group)

RAD
expression

Any valid RAD expression that returns an email address, a
contact name, an operator name, or an array of values.
Multiple values can be entered and must be separated by a
semi-colon (;).

jscall(<lib.function>,
contact.name in
$L.file)
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Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by email. If an

email client is configured on this system, click the link above and an email window opens with the

following information in the subject line:

Feedback on Survey help topics for printing (Service Manager 9.41)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web mail client, and

send your feedback to ovdoc-ITSM@hp.com.

We appreciate your feedback!
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