Troubleshoot > ITOC issues and use cases

HPE ITOC issues and use cases

Problem: All HPE ITOC services seem to be running, but nothing is accessible through the UI.

Symptoms

In the JBoss /opt/hp/itoc/log/server/server.log file, you see content similar to the following:

2015-05-22 11:42:02,408 INFO [org.jboss.as] (Controller Boot Thread) JBAS015874: WildFly 8.1.0.Final "Kenny" started in 71512ms - Started 562 of 624 services (107 services are lazy, passive or on-demand)

2015-05-22 11:58:43,212 ERROR [org.jboss.as.controller.management-operation] (DeploymentScanner-threads - 1) JBAS014612: Operation ("read-resource") failed - address: ([("deployment" => "ocm.war")]): java.lang.OutOfMemoryError: Java heap space

2015-05-22 11:58:43,213 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015018: Deployment ocm.war was previously deployed by this scanner but has been removed from the server deployment list by another management tool. Marker file /opt/hp/itoc/wildfly-8.1.0.Final/standalone/deployments/ocm.war.undeployed is being added to record this fact.

...

2015-05-22 11:58:44,401 ERROR [stderr] (OCMScheduler Resource Worker Tasks-7-29) Exception in thread "OCMScheduler Resource Worker Tasks-7-29" java.lang.OutOfMemoryError: Java heap space

Primary software component

JBoss

Possible cause

An unrecoverable error occurs, such as Out Of Memory conditions, causing JBoss to fail to deploy any of the web services context.

Solution

Enter the following:

cd /opt/hp/itoc/wildfly-8.1.0.Final/standalone/deployments

mv idm-service.war.undeployed idm-service.war.dodeploy

mv ocm.war.undeployed ocm.war.dodeploy

/opt/hp/itoc/scripts/appserver restart

 

Problem: Stopping the HPE ITOC service results in intermittent error.

Symptom

When you stop the HPE ITOC service, you may see output similar to the following:

$ service itoc stop

Stopping Salt...

Stopping salt-master daemon: [ OK ]

Stopping salt-minion daemon: [ OK ]

Stopping HP ITOC service

...

Error occurred cannot stop the process

Possible solution

Make sure that /etc/hosts is similar to the following:

127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4

::1 localhost6 localhost6.localdomain6

Workaround

Wait for a short time, then try stopping the service again.

Look for the Java process: #ps –ef|grep “java” | grep <itoc_install_directory> , and kill this process.

 

Problem: The maintenance window Job view has only time slot info without any status.

Symptom

In the maintenance window Job view, there is a time slot record but it does not have any job status.

Possible causes

There are three possible causes:

  • The maintenance window type is Scan, and it is scheduled to perform a scan against an SOA in which the last scan occurred halfway within the MSLO limit. If this is the case, you will see entries such as the following in <itoc_install_directory>/log/server/hpitoc-server.log:

    2015-09-18 19:30:00,684 DEBUG [ItocQuartzJobScheduler_Worker-1] c.h.o.s.s.a.ItocAssemblageQueryAdapter [ItocAssemblageQueryAdapter.java:497] Rule in 0.5 of MSLO. Will not measure.

  • The maintenance window type is either Remediate or Scan and Remediate, and it is scheduled to remediate an SOA in a state other than Non-Compliant. If this is the case, you will see entries such as the following in <itoc_install_directory>/log/server/hpitoc-server.log:

    2015-09-18 20:00:00,690 INFO [ItocQuartzJobScheduler_Worker-3] c.h.o.s.c.s.ComplianceService [ComplianceService.java:627] ComplianceService.checkRunningOrFutureJobs: Nothing to execute for REMEDIATION 3

    2015-09-18 20:00:00,694 INFO [ItocQuartzJobScheduler_Worker-3] c.h.o.s.s.a.ItocAssemblageQueryAdapter [ItocAssemblageQueryAdapter.java:581] Nothing to Scan or Remediate

  • One SOA is assigned to multiple maintenance windows, and the maintenance windows scheduled start time or duration overlap with each other.