Searching the Help
To search for information in the Help, type a word or phrase in the Search box. When you enter a group of words, OR is inferred. You can use Boolean operators to refine your search.
Results returned are case insensitive. However, results ranking takes case into account and assigns higher scores to case matches. Therefore, a search for "cats" followed by a search for "Cats" would return the same number of Help topics, but the order in which the topics are listed would be different.

Search for | Example | Results |
---|---|---|
A single word | cat
|
Topics that contain the word "cat". You will also find its grammatical variations, such as "cats". |
A phrase. You can specify that the search results contain a specific phrase. |
"cat food" (quotation marks) |
Topics that contain the literal phrase "cat food" and all its grammatical variations. Without the quotation marks, the query is equivalent to specifying an OR operator, which finds topics with one of the individual words instead of the phrase. |

Search for | Operator | Example |
---|---|---|
Two or more words in the same topic |
|
|
Either word in a topic |
|
|
Topics that do not contain a specific word or phrase |
|
|
Topics that contain one string and do not contain another | ^ (caret) |
cat ^ mouse
|
A combination of search types | ( ) parentheses |
|
Installation and initial configuration
Problem: HPE ITOC startup fails on the CentOS 6 server. The user cannot access the UI as the authentication/authorization service fails.
Symptom
A message similar to the following appears in the server.log
file on service startup.
acquireIncrement -> 3, acquireRetryAttempts -> 30, acquireRetryDelay -> 1000, autoCommitOnClose -> false, automaticTestTable -> null, breakAfterAcquireFailure -> false, checkoutTimeout -> 0, connectionCustomizerClassName -> null, connectionTesterClassName -> com.mchange.v2.c3p0.impl.DefaultConnectionTester, dataSourceName -> 1hgevfi9bmopcz4k66x0l|7ac02973,debugUnreturnedConnectionStackTraces -> false, description -> null, driverClass -> org.postgresql.Driver, factoryClassLocation -> null, forceIgnoreUnresolvedTransactions -> false,identityToken -> 1hgevfi9bmopcz4k66x0l|7ac02973, idleConnectionTestPeriod -> 0, initialPoolSize -> 20, jdbcUrl -> jdbc:postgresql://itoc158.qa.opsware.com:5432/itoc, lastAcquisitionFailureDefaultUser -> null, maxAdministrativeTaskTime -> 0, maxConnectionAge -> 0, maxIdleTime -> 0, maxIdleTimeExcessConnections -> 0, maxPoolSize -> 250, maxStatements -> 0, maxStatementsPerConnection -> 0, minPoolSize -> 20, numHelperThreads -> 3, numThreadsAwaitingCheckoutDefaultUser -> 0, preferredTestQuery -> null, properties -> {user=******, password=******}, propertyCycle -> 0, testConnectionOnCheckin -> false, testConnectionOnCheckout -> false, unreturnedConnectionTimeout -> 0, usesTraditionalReflectiveProxies -> false
]...
Caused by: org.postgresql.util.PSQLException: Connection refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.
Primary software component
CentOS
Possible cause
It reproduces intermittently only when service is started using a native service subsystem such as service itoc start
, which also occurs automatically when performing an install as a root user.
Solution
Stop the HPE ITOC service, and restart the service using <install_dir>/scripts/itoc start
.
Problem: When running HPE ITOC as a non-root user and the HPE ITOC install uses a JDK that was previously installed as root, you will see warning messages in the server.log file.
Symptom
There are many warning messages in <itoc_install_location>/log/server/server.log*
, such as the following:
2015-05-11 12:48:18,826 WARNING [java.util.prefs] (Timer-2) Couldn't flush system prefs: java.util.prefs.BackingStoreException: /etc/.java/.systemPrefs/com create failed.
Primary software component
JDK
Possible cause
The licensing component used by HPE ITOC is trying to access the preference store that triggers this warning. This has no functional effect.
Solution
This warning can be ignored. If the user running HPE ITOC has permissions on the JDK install, then no warning will occur.
We welcome your comments!
To open the configured email client on this computer, open an email window.
Otherwise, copy the information below to a web mail client, and send this email to hpe_itoc_docs@hpe.com.
Help Topic ID:
Product:
Topic Title:
Feedback: